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The Main List helps you organize your related sequences and output files into
project files. For each project you can use the Main List to “build” list files.
List files contain a list of sequence specifications, including single database
sequences (such as ba:ecoompa), multiple database sequence specifications
(such as ba:*), personal sequence files, MSF files, RSF files, and other list files.
To switch from working on one project to working on another, you simply

load a different list file into the Main List mode of the Main Window.

From the Main List you can select sequences to submit to programs. In
addition, you can define sequence attributes, including sequence ranges,
orientation, topology, and weight, as well as concatenations with other
sequences.
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The Main List

The Main List is a project manager that provides a good method of organizing
the sequences with which you are working. From this mode, you group
project-related sequences and analysis results in list files which you can
easily load into the Main List or the Editor. (A list file contains a list of
sequences and their locations. For more information about list files, see
Appendix C, Types of Sequence Files.)

The Main List lets you point to and use sequences in the databases without
first copying them to your directory and thus using up disk space. You can
add database sequences, sequences from personal directories, RSF files, MSF
files, and nested list files to the Main List. The Main List saves the items you
load into a single list file. When you want to switch to a different project,
you simply load or create a different list file in the Main List.

The Main List makes it easy for you to work with the sequence files in your
projects. From this window you can select sequences to load into the Editor,
use sequences as input to a program, add new sequences to or remove
sequences from a project, search through items in a list, view and change
sequence attributes, and extract sequences into a different format, among
other tasks. You can organize these sequences by project and load a different
list file into the Main List as needed.
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The first time you use SeqLab, the Main List will be empty with the name
working.list.

4 Seglab Main Window on bangs M= 3
File Edit Functions Extensions Options Windows Help |
List: I fusr/users/smith/working. list @
Mode:  Main List — I

Begin End List Item

Once you add your sequences to the Main List and create list files, SeqLab
opens with the last file you were working with each time you begin a
subsequent session with SeqLab.
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Displays the
sequence type:
nucleic (N),
protein (P),
ambiguous (%),

The illustration below shows the features of the Main List.

Indicates the strand
orientation: forward (+)
or reverse (-).

Shows the begin and

or unknown (*).

Menu bar

Names the currently
loaded list file

Mode selector toggles
between Main List
and Editor modes.

Scroll bars let you
move from left to
right, allowing you to
view the list item

comments on the right.

end position of the sequence.
Names each item in the
list file currently displayed.
-4 feglLab Main Window on bangs M= 3
Fille Edit| Functions Extepsions Options Windows Help
List: I/usr users/smith/projgct.list @
tpde: Miin List — I
Begin End List Item
usr/users/snith/pileup_1.msf {x} X
1 50| swissprot:hspl_human

@/usr/users/smith/lookup.list

1 888| gb_prl:hspcaiii
@/usr/users/smith/searchset_1.1list
@/usr/users/snith/tutorial.list
487 | gb_pr1:hspbr2

645| gb_pr1:hspbr3

684| gb_pr1:hspbrd

328| gb_pr1:hspigal =
1069| gb_pr1:hspiga2

453| gb_pr1:hspiga3
Invertebrate:hsp*
@/usr/users/smith/hsp cds.list
1161 1257 GB_IH: BRPHSPAL—>BRPHSPAL -G
1650 1754 GB_IH: BRPHSPAL—>BRPHSPAL -G
1908 2269 GB_IH: BRPHSPAL—>BRPHSPAL -G
2348 2471 GB_IH: BRPHSPAL—>BRPHSPAL -G
2587 2737 GB_IH: BRPHSPAL—>BRPHSPAL -G
2841 3099 GB_IH: BRPHSPAL—>BRPHSPAL -G
3226 3447 GB_IH: BRPHSPAA—>BRPHSPAL-G
3616 3963 GB_IH: BRPHSPAL—>BRPHSPAL -G
4039 4225 GB_IH: BRPHSPAL—>BRPHSPAL -G

. 3

The —> arrow indicates

EEEEEEE R EEE - E RS
+ o+ttt FtrF A+ F

il

that the sequences Scroll bars let you

can be joined by those dlspl?yta”fltemst in
your list—from top

programs that support the {5 bottom.

Join: sequence attribute.

Note: Some sequences may not display the sequence type, strand orientation,
or begin and end positions until you use them as input to a program or until
you double—click them to view the sequence attribute information. Because of
this, the sequence type may display as ambiguous (*), the sequence strand
orientation may display as a forward strand (+), and the begin and end
position may appear blank until you use the sequence.
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What are List Files?

List files are what their name implies: a file containing a list of sequences.
You can think of list files as a way to organize your sequences on a
project-by—project basis. In addition to database sequences and individual
sequences in your own directories, list files also can contain RSF files, MSF
files, and other list files. (See Appendix C, Types of Sequence Files.)

List files optionally also may contain sequence attributes, such as the
beginning and ending position of the sequence, the strand (forward or
reverse), sequence topology (linear or circular), sequence weight, and
sequence joining.

For more information about list files and the sequences they can contain, see
Appendix C, Types of Sequence Files.
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Opening a New or Existing List File

Before you can run programs in SeqlLab, you must create a new list file or
open an existing one. This section teaches you how. For information on
how to add sequences to a list file, see “Adding Items to a List” in this
chapter.

Creating a New List File

You can create list files in three ways: 1) the easiest way is to create them
from scratch using Seqlab; 2) you can save a subset of sequences from one
list file as a new, separate list file; and 3) you can run programs that create list
files as their output.

P To create a new list file from scratch:
1. From the Main List, choose New List... from the File menu. The New List

File dialog box appears.

Mame of new list file:

|1 |
oK | Cancel |

2. Click the mouse pointer in the Name of new list file: text box and type
the name of the new list file. If you do not specify a directory, the list
file will be created in your working directory.

3. Click OK. An empty list window appears with the name of your new list
file displayed at the top.

To add sequences to a list file, see “Adding Items to a List” in this chapter.
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P> To save a subset of sequences from one list file as a separate, new list
file:

1. In the Main List, select the sequences you want.

2. From the File menu, choose Save Selected.... The Save Selected List
dialog box appears, prompting you to name the new list file.

4 Save Selected List [ %]

Mame of Selected List

| |
oK | Cancel |

3. Type the name of the new list file in the Name of Selected List text box
and click OK. The list file is written in your working directory, unless
you specify a different one.

To open the new list file in the Main List, see “Opening an Existing List
File” in this chapter.
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P Wisconsin Package programs that produce output in list file format:

Required parameters and the location of the program within the Functions
menu also are listed below.

Note: Some of the programs may include additional program-specific
information in the output list file. This extra information will not affect the
list file’s performance.

Program Required parameter(s) Functions menu location

Assemble In the Assemble program Editing and Publication
window, select the “List file
of output sequence names”
toggle button and type a
name for the list file in the

text box.
BLAST 1. In the BLAST program Database Sequence
window, click Search Searching

Set.... The Choose a
Search Set for BLAST
dialog box appears.

2. Choose a local
database.

Corrupt In the Corrupt program Manipulation
window, select the “List file
of output sequence names”
toggle button and type a
name for the list file in the

text box.
FastA o Database Sequence
Searching
FastX o Database Sequence
Searching
FindPatterns 1. In the FindPatterns Database Sequence

program window, click  Searching
on Options.... The

FindPatterns Options

window appears.

2. Select the “Format
output as a list file of
sequence names” toggle
button.
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Program

Required parameter(s)

Functions menu location

FromEMBL

In the FromEMBL program
window, select the “List file
of output sequence names”
toggle button and type a
name for the list file in the
text box.

Importing/Exporting

FromFastA

In the FromFastA program
window, select the “List file
of output sequence names”
toggle button and type a
name for the list file in the
text box.

Importing/Exporting

FromGenBank

In the FromGenBank
program window, select
the “List file of output
sequence names” toggle
button and type a name for
the list file in the text box.

Importing/Exporting

FromIG

In the FromIG program
window, select the “List file
of output sequence names”
toggle button and type a
name for the list file in the
text box.

Importing/Exporting

FromPIR

In the FromPIR program
window, select the “List file
of output sequence names”
toggle button and type a
name for the new list file in
the text box.

Importing/Exporting

Motifs

1. In the Motifs program
window, click
Options.... The Motifs
Options window
appears.

2. Select the “Write output
file in list file format”
toggle button.

Protein Analysis or
Database Sequence
Searching

MotifSearch

Database Sequence
Searching
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Program Required parameter(s) Functions menu location
Pretty 1. In the Pretty program Multiple Comparison
window, select the
“Write the individual
sequences in a PRETTY
file into separate
sequence files” toggle
button.
2. In the “List file of output
sequence names’” text
box, type a name for
the list file.
ProfileSearch Database Sequence
Searching
Reformat In the Reformat program Importing/Exporting
window, select the “List file
of output sequence names”
toggle button and type a
name for the list file in the
text box.
Sample In the Sample program Utilities—> Sequence Utilities
window, select the “List file
of output sequence names”
toggle button and type a
name for the list file in the
text box.
SSearch o Database Sequence
Searching
StringSearch - Database Reference
Searching
TFastA — Database Sequence
Searching
TFastX L Database Sequence
Searching
Translate In the Translate program Translation
window, select the “List file
of output sequence names”
toggle button and type a
name for the list file in the
text box.
WordSearch Database Sequence

Searching
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Opening an Existing List File

P To open an existing list file in the Main List:

1. Choose Open List... from the File menu. The Open List File dialog box

appears.
Popen Listie |
Filter

I/usr/users/smith/*.lisﬁ

Directories Files
BN - | hs70.list B
.. hsp_hunan. list

.dt 1dh.1list

.hetscope lookup.list
.seqlab-bangs mylist.list
.seqlab-screech new.list

. seqlab-squawk opsin.list

. 5Yysnan s |project.list v
|5 —_ |5 N
Selection

I/usr/users/smith/I |
ok | | Fitter | | Cancel| | Help |

2. Use this box to select a list file and click OK. SeqLab loads the selected
list file into the Main List.
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Selecting Sequences

P To select one or more sequences from the Main List:
Choose from the following.

2@ Click or drag the mouse in combination with using <Shift> and <Ctrl> to
select sequences. For more information, see “Selecting Items with the
Mouse” in the “Using the Mouse” topic of Chapter 1, Basic Concepts.

Note: You can select individual sequences within RSF, MSF, and nested
list files to analyze or use as input to a program. To do so, expand the RSF
[file, MSF file, or list file into its individual entries. For more information,
see “Expanding List Files, RSF Files, and MSF Files in a List” in this

chapter.

&8 Select All. Choose Select All from the Edit menu to select all sequences
currently loaded in the Main List.
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Expanding List Files, RSF Files, and MSF Files in a List

You can expand nested list files, RSF files, and MSF files to display the
individual items within them. Note, however, that you cannot expand a
database specification that includes a wildcard, for example GenEMBL:alu* .
For more information, see Appendix C, Types of Sequence Files.

P To expand a nested list file, RSF file, or MSF file in the Main List:

Double—click on the nested list file, RSF file, or MSF file. The entry expands
into its individual entries below the item in the Main List. Note that the Main
List can display a maximum of 2,000 items. If you expand a file that exceeds
that limit, SeqLab displays only enough sequences to reach that limit.

P To un-expand an expanded item:

Double—click on the item again to remove the individual entries from the
display.

Note: Once you have expanded a list file, RSF file, or MSF file, you cannot use
it as input to a program. If you want to select the entire RSF, MSF or list file
and it is expanded, double—click on the entry to un-expand it, and then select
it.
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List file before

4 Seqlab Main Window on bangs M=l E3

File Edit Functions Extensions Options Windows Helpl
List: I /usr/users/smith/working. list @
Begin End List Item

expansion

Expanded list file

Individual entries
within an expanded
list file. Note that
these entries are
indented.

T 1 ——&/usr/users/smith/hsp_human. list

File Edit Functions Extensions Options Windows Help |
List: I /usr/users/smith/working. list @
tode: | Main List — I

Begin End List Item

=+ @/usr/users/smith/hsp_human. list
P|+ 1 643 rsu:hs?ﬁ_humun
Pl 1 641 sw:hs? 1_human
P|+ 1 646 Lsu:hs?c_humun
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Adding Items to a List

You can add your own personal sequence files, RSF files, MSF files, other list
files, and database sequence files to the Main List.

Database Sequences

P To add database specifications to the Main List:

From the File menu choose Add Sequences From —> Databases.... The
Database Browser appears, allowing you to choose sequences from the
various databases available at your site.

4 Seglab Database Browser M=l E3 I

tdain Database Browser
Databases: Entries:

SwissProt

SPTREMBL
SP_iArchea
SP_Fungi
SP_Hunan Bext 200 Matches |
SP_Invertebrate
SP_HMannal
SP_Hhc
SP_Organelle
SP_Phoge
SP_Plant
SP_Bacteria
SP_Rodent
SP_Virus
SP_Vertebrate
SP_Unclaossified

SwissProtPlus

PIR

GenEMBL
Bacterial v

Ll

Show Matohing i-ﬁ-ﬁzz‘?;z'égfss|

Provigus P00 ?Jééﬁ%c%wsd

Database Specification:

|Add to Main Windowl View Sequence| Close| HeIpI

For more information, see Chapter 8, Using the Database Browser.
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Single or Multiple Sequence Files

P To add single sequence files, list files, RSF files, or MSF files to the Main
List:

1. From the File menu choose Add Sequences From —> Sequence Files....
The Add Sequences file selection box appears, allowing you to choose
sequence files from available directories.

A Add Sequences [ %] I
Filter

I/usr/users/smith/*.seq

Directories Files
B - | cal6srdnp.seq |-
.. dncanr . seq

.dt ganna. seq
.hetscope

.seqlab-bangs
.seqlab-screech

. seqlab-squawk

. SYsman v

I —_ |5 JR—

.

Selection
I/usr/users/smith/I |

Add | Filter| |Close| | Help |

2. Select the sequence file(s) you want.

Note: You can add only GCG-formatted sequences to the Main List. To
add non-GCG-formaitted sequences, see the following task.

3. Click the Add button. The sequence(s) are added to the Main List.

4. Click the Close button when you are finished.
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P To add non-GCG-formatted sequences to the Main List:

Note: You can also add non-GCG-formaited sequences directly into the
Editor. To do so, use the Import... function from the File menu in the Editor.
For more information, see “Loading FastA, GDE, or GenBank Flat Files into
the Editor” in the “Loading Sequences into the Editor” section of Chapter 2, The
Editing Sequences and Alignments.

1. From the Functions menu, click on Importing/Exporting to select from
the available programs. Choose from the following:

i  Reformat. Formats files created with a text editor to create
GCG-format files.

Note: The text file you create as input to the Reformat program has
specific format requirements. For more information, see Reformat in
the Program Manual.

2  FromEMBL. Reformats files in EMBL flat file format to GCG format.
8  FromPFastA. Reformats files in FastA format to GCG format.

i  FromGenBank. Reformats files in GenBank flat file format to GCG
format.

2  FromPIR. Reformats files in PIR flat file format to GCG format.
i  FromlIG. Reformats files in IntelliGenetics format to GCG format.
i  FromStaden. Reformats files in Staden format to GCG format.

The main window for the program you selected appears. (For more
information on these programs, see the Program Manual.)
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Choose from the following:
& If you selected Reformat:

a. Click on the “Reformat non-GCG sequence file(s) into GCG
format” toggle button.

b. Click on the File Specification... button to display and select the
file you want to reformat from a file selection box, or type the
file specification directly in the text box to the right of the File
Specification... button.

& If you selected FromEMBL, FromFastA, FromGenBank, FromPIR,
FromlIG, or FromStaden, click on the “Format sequence data file...”
button to display and select the file you want to reformat from a file
selection dialog box, or type the file specification directly in the text
box to the right of the “Format sequence data file...” button.

(] Tip If you are reformatting more than one sequence using
Reformat, FromEMBL, FromFastA, FromGenBank, FromPIR,
FromlIG, or FromStaden, the easiest way to recover the
output files is to supply a list filename in the “List file of
output sequence names” text box. After you run the
program, the list file will appear in the Job Manager window,
and will contain the names of the individual output files that
were created.

Select any other optional parameters you want.

On the main program window, specify how to run the program by
selecting a method from the How: option menu and click Run. The job
appears on the Job Manager window, and when it is finished running,
output appears on the Output Manager window.

The output is written in your working directory.

From the Windows menu, choose Output Manager. The Output Manager
window appears.
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6. Select the newly formatted GCG sequence file from the list of output
files.

a. (optional) If you want to rename the file, click Save As.... A dialog
box appears, allowing you to specify a new name. Type the new
name and click Save. The dialog box closes and you return to the
Output Manager.

b. With the file still selected, click the Add to Main List button.
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Adding Comments to a List File

You can add comments to a list file to help you remember the type of
sequences you have included, their significance, and when they were
created, among other information.

P To add comments to a list file:

1. In the Main List, open the list file to which you want to add comments.

2. From the Edit menu, choose List Description.... The List Description
dialog box appears.

A List Description

= — |

= j

Close I

Note: If you created a list file as output from a Wisconsin Package
program, the program may display program and sequence comments in
the List Description dialog box. You can add to or delete from existing
comments.

3. Click the cursor in the window and type your comments.

4. When you are finished, click the Close button. To save your comments,
from the File menu, choose Save List.

To view a list file’s description, choose List Description... from the Edit
menu.

Managing Your Sequence Projects [ 6-21



List Item Attributes

The items in a list file may have several attributes in addition to their filename
or database specification. These attributes include:

*

Begin Position. (Begin:zz) Shows the base position you want to start
with in the sequence, where 7 = 1 to the length of the sequence.

End Position. (End:»z) Shows the base position you want to end with
in the sequence, where 7 = 1 to the length of the sequence.

Strand: Forward or Reverse. (Strand:+ or —) Defines the forward or
reverse sequence strand, where + = the forward strand and - = the
reverse strand.

Sequence Topology: Linear or Circular. (Circ:F or T) Defines the
sequence strand as linear or circular, where F = linear and T = circular.

Sequence Weight. (Wgt:z2.727) Defines the significance of the sequence
in comparison to other sequences. That is, you may not want all
sequences accounted for equally to determine a result. Therefore, you
can weight some greater than others. This attribute is of use only when
you are using two or more sequences in the analyses.

Join. Indicates that the sequence is joined, or concatenated, with the
next sequence in the list that has an identical “Join:  name’ attribute.
(Assemble, Translate, and LookUp are the only Wisconsin Package
programs that use the Join attribute.)

Note: Currently, Assemble, CodonFrequency, Distances, Diverge,
FrameSearch, PileUp, PlotSimilarity, ProfileMake, Seg, Translate, and Xnu use
some or all of these sequence attributes.
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The Main List window displays some of the sequence attributes. To view all
sequence attributes, see “Viewing Sequence Attributes” next in this chapter.

Strand:
forward (+) or reverse (-).

Begin position and
End position

3eqlab Main Window on bangs

Fjle Edit | Functions Extensions Options Windows Help |
Ligt: I/usr/ sers/smith/project.list @
hode: Mai! List — I
Begin End List Item
* |+ usr/users/smith/pileup_1.msf {x} A
P|+ 1 50| swissprot:hspl_human
x|+ @/usr/users/smnith/lookup.list
M|+ 1 888| gb_prl:hspcoiii
|+ @/usr/users/smith/searchset_1.1list
x|+ @/usr/users/snith/tutorial.list
M|+ 1 487 | gb_pr1:hspbr2
M|+ 1 645| gb_pr1:hspbr3
M|+ 1 684| gb_pr1:hspbrd
M|+ 1 328| gb_pr1:hspigal
M|+ 1 1069| gb_pr1:hspiga2
M|+ 1 453| gb_pr1:hspiga3
* |+ Invertebrate:hspx
|+ @/usr/users/smith/hsp cds.list
* |+ 1161 1257 GB_IN: BRPHSPAA—>BRPHSPAL—6
* |+ 1650 1754 GB_IN: BRPHSPAA—>BRPHSPAL—6
* |+ 1908 2269 GB_IN: BRPHSPAA—>BRPHSPAL—6
* |+ 2348 2471 GB_IN: BRPHSPAA—>BRPHSPAL—6
* |+ 2587 2737 GB_IN: BRPHSPAA—>BRPHSPAL—6
|+ 2841 3099 GB_IN: BRPHSPAL—>BRPHSPAL-G
* |+ 3226 3447 GB_IN: BRPHSPAA—>BRPHSPAL—6
* |+ 3616 3963 GB_IN: BRPHSPAA—>BRPHSPAL—6
|+ 4039 4225 GB_IN: BRPHSPAA—>BRPHSPAL—6 ;
-4 -

Join :

Sequences with identical join
names can be concatenated
into a single sequence. The
join name appears to the right
of the —> arrow.
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Viewing Sequence Attributes

P To view the attributes of items in a list:

In the Main List, double—click on the single sequence you want to view. A
Sequence View dialog box appears, displaying the sequence attributes as well
as the reference and sequence itself.

Mucleotide Sequence:l gb_pr 1:hspbr2 | Length: 487
Begin II “ Forward || <> Linear | Weight:
End: 187 <, Reverse || <, Circular | Join:
Reference:
Locus HSPBR2 487 bp DHA PRI 20-HAY-1994 j
DEFINITION Human peripheral benzodiazepine receptor gene, exon 2.
ACCESSION L21952
HID g483403
KEYHWORDS benzodinzepine receptor; peripheral benzodiozepine receptor. ‘
]
-

Sequence:

CTGARATGCG
TGATCAGCTG
GAGGAGACAC
TGTCTTCTCT
CCGCCCTGGG
CTTCGTGGGC
GCCTGCAGHA
TGGGGCACGC
GGATAAGCCT

TTCACTCAGC
ACTGGTTGAT
GGGCCTGACC
TTCAGAGCTC
TGCCCGCCAT
TCCCGCTTTG
GCCCTCGTGG
TCTACTCAGC
GGCCCTTTGC

CACTCCCACC
CTGTGGGTGA
CCATGGCCTC
CCCTGAACAG
GGGCTTCACG
TCCACGGCGA
CACCCGCCCC
CATGGGGTAG
AAGGGGAGGC

CCGCACATCT
CAGGCCTTTC
GGAATGCCCT
CAGCTGCAGC
CTGGCGCCCA
GGGTCTCCGC
ACTGGGTGCT
GTGGGCGTGC
CTGGCCCAGG

CTGCGCCTCC
GGGGATGCTG
CACGCAGCCC
AGCCATGGCC

GCCTGGGGTG
TGGTACGCCG
GGGCCCTGTC
ACTGGCCT GG
ACAGAGGGTC

=]

OK | Cancel| Apply| Create As Mew Entry| Print Sequence...|

S E—

——Handle

You can view the attributes of only single sequences by double—clicking on
them. You cannot view multiple sequence specifications in this manner.

[J Tip Click and hold on the handle and drag vertically to resize the
Reference: or Sequence: paned windows.
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Editing List Item Attributes

You can modify the attributes of a single sequence at a time, multiple
sequences in a list, or the entire list.

P To change the attributes of a single sequence:

Note: You cannot edit an item that is within a nested list, RSF, or MSF file. If
you try to to do so, Seqlab asks whether you want to copy that edited item to
the Main List as a separate sequence.

1. Double—click on the sequence you want to modify. An expanded
Sequence View dialog box appears.

Mucleotide Sequence:l gb_pr 1:hspbr2 Length: 487
You can edit Begm:lflﬁﬁ “ Forward || © Linear | Weight: I .000000
the attributes End: [7 A Cireul R
area onIy. < Reverse || <, Circular | Join: I
Reference:
Locus HSPBR2 487 bp DHA PRI 20-HAY-1994 j
DEFINITION Human peripheral benzodiozepine receptor gene, exon 2
ACCESSION L21952
HID g483403
KEYHWORDS benzodinzepine receptor; peripheral benzodiozepine receptor. ‘
] I
o

Sequence:

1 CTGARATGCG TTCACTCAGC CACTCCCACC CCGCACATCT CTGCGCCTCC
51 TGATCAGCTG ACTGGTTGAT CTGTGGGTGA CAGGCCTTTC GGGGATGCTG
101 GAGGAGACAC GGGCCTGACC CCATGGCCTC GGAATGCCCT CACGCAGCCC
IEIIREES NI IS RN ¥ IEAGCTC CCCTGAACAG CAGCTGCAGC AGCCATGGCC
CCGCCCTGGG TGCCCGCCAT GGGCTTCACG CTGGCGCCCA GCCTGGGGTG
CTTCGTGGGC TCCCGCTTTG TCCACGGCGA GGGTCTCCGC TGGTACGCCG

GCCTGCAGHAA GCCCTCGTGG CACCCGCCCC ACTGGGTGCT GGGCCCTGTC
TGGGGCACGC TCTACTCAGC CATGGAHIISNYIEHE Il T I | e
401 GGATAAGCCT GGCCCTTTGC AAGGGGAGGC CTGGCCCAGG ACAGAGGGTC

S E—

= j

OK | Cancel| Apply| Create As Mew Entry PrintSequence...|

Note: The reference and sequence areas are displayed only when you
double—click on a single sequence. If you choose Change Attributes from
the Sequences menu, only the attribute and action button areas are
available.

The reference and sequence areas are display only (non-editable), and
you can use the scroll bars to view information that is out—of-view. If
the item is a database sequence, the reference area contains information
such as the sequence name, definition, accession number, keywords,
source, begin and end positions of known sequence features, and known
other information.
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] Tip To change the begin and end positions of a sequence, type
directly in the Begin: and End: text boxes. Or, click and drag to
highlight the area of interest in the Sequence: area of the dialog
box and click the Apply button. The Begin: and End: text boxes
change to reflect the portion of the sequence you highlighted.

2. Change the attributes you want by typing in the text boxes or clicking the
appropriate radio buttons in the attributes area.

Note: To edit the sequence characters, load the sequence into the Editor.

3. Save your changes and return to the Main List. Choose from the
following action buttons:

@  OK. Changes the attributes for the selected entry in the Main List to
the values currently specified in the Sequence View dialog box, and
the dialog box closes.

2 Cancel. Closes the dialog box without applying any changes since
the last Apply to the selected entry in the Main List.

3 Apply. Changes the attributes for the selected sequence in the Main
List to the values currently specified in the Sequence View dialog
box. The dialog box remains open.

i Create As New Entry. Adds a new entry to the top of the Main List,
using the sequence attributes currently specified in the Sequence
View dialog box. The dialog box remains open.

[] Tip Use the Create As New Entry button to create items in the
Main List that are duplicates of existing sequences except for
their attribute values. That is, you could have multiple
copies of a sequence in a list file, each copy varying the
sequence attributes. This option may come in handy if you
find yourself changing the attributes of existing sequences
temporarily to use with select programs.

2 Print Sequence.... Displays a Print Text dialog box, from which you
can specify a printer. The sequence data, excluding the attributes, is
printed. For more information, see “Printing from the Main List or
from the Database Browser” in Chapter 12, Printing.
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P> To change the attributes of multiple sequences in a list or an entire list:

1.

Select the sequences of interest from the Main List. You can select single
sequence entries, database entries, MSF files, RSF files, or nested list files.
To change attributes for all sequences, choose Select All from the Edit
menu.

Choose Sequence Attributes... from the Edit menu. The Sequence View
dialog box appears.

4 Sequence Yiew [ %]

Begln:l-i- — ] & Forward || < Linear Weight:II
End: I <+ Reverse || <, Circular | ] Edit join

ol I
| OK ICanceI| Apply|

Edit the attributes you want. To change the Join: attribute, click the Edit
join toggle button, then add or modify the join name in the Join: text
box.

Click Apply to save the attribute changes.

Click OK to exit from the dialog box.
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If you change the attributes of an RSF, MSF, or nested list file, those attributes
take precedence over any attributes specified for individual sequences within
those files. Note that the attributes you specify for an RSF, MSF, or nested list
file appear next to the item on the Main List. However, if you double—click
on the file to expand it into its contents, the individual sequences within
those files maintain their original attributes. This is advantageous if the

individual sequence attributes are of scientific value.

4 Seqlab Main Window on bangs

File Edit Functions Extensions Options Windows

M=l B3
Help |

Ust:I/usr/users/smith/uurking.list

tMode:  Main List — I

A

Begin End List Item

[+] |
P|+| 1] 643 | suw: hs?6_hunan
P|+| 1] 641 suw:hs? 1_hunan
P|+]| 1] 646 | suw: hs?c_hunan

You can change the
attributes for an
entire list, RSF , or
MSF file.

The individual
items within the file
maintain their
attributes.
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Deleting Files

At some point you probably will want to clean up your list files and delete
items within them that are no longer of interest to you. You can do this by
loading a list into the Main List and selecting those items you do not want.

You have two options for deleting items: 1) you can simply remove the
item(s) from the list, but the file remains in its current directory in case you
want to use it later, or 2) you can delete the file from disk.

Note that you cannot remove individual items from within an RSF, MSF, or
nested list file that is expanded into its individual items. If you choose an
item from within an RSF, MSF, or nested list file and try to remove it, you will
get an error message. To remove an item from a nested list file, you must
open that file separately in the Main List and delete the item. To remove

sequences from an RSF or MSF file, load the file into the Editor and modify it
as necessary.

Removing Items from a List

P To remove items from a list:

1. Select the sequences you do not want.

2. From the Edit menu choose Remove from List. The selected sequences
are removed from the Main List.

Deleting Files from Disk

P To delete files from disk:

1. Select one or more items from the Main List that you do not want.

2. From the Edit menu choose Delete File from Disk.... Seqlab prompts you

before deleting the file(s) from disk.
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] Tip One way to remove one or more sequences in an MSF file is to
“comment out” those you do not want. If you comment out
sequences instead of deleting them, you can uncomment them
and use them at a later time.

To comment out sequences, follow these steps:

1. From the operating system prompt, open the MSF file in the
text editor of your choice, for example (OpenVMS) EDT or
EVE or (UNIX) vi.

2. Find the sequences you do not want to use in the
Name/Weight area toward the top of the file.

3. Type an exclamation point (!) in front of the “Name:” of each
sequence you do not want. Consider the illustration below:

Picorna virus capsid proteins

Picorna.Msf MSF:100 Type: P September 1, 1994 01:53 Check:541 ..
Comment out unwanted

Zig;\?;‘;ﬁsnwgg ri”(') Y IName: Cb3 Len: 100 Check: 7009 Weight:  1.00
o IName: E Len: 100 Check: 60 Weight:  1.00

Name: Plm Len: 100 Check: 7401 Weight: 1.00

Name: Pls Len: 100 Check: 6071 Weight: 1.00

4. Save the file and exit the text editor. Only those file that are
not commented out will appear when you expand the MSF
file in the Main List.
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Searching for Items in a List

Sometimes list files may become very large, and you may find it difficult to
identify a particular item you are looking for. In such a case, SeqlLab has a
Find... function that lets you search the sequence and comments area for a
particular word or string of words. SeqLab searches only through the list item
names and comments that appear in the Main List—it does not search
through sequence reference information or through sequence data. In
addition, SeqLab does not search through RSF, MSF, or nested list files unless
you first expand them (see “Expanding List Files or MSF Files in a List” in this
chapter). Also, SeqLab does not search through the sequences implied by
multiple sequence specifications using a wildcard (¥).

P To search for items in the Main List:

1. From the Edit menu, choose Find.... The Search List dialog box appears,
with a text area to enter the text string you want to search for.

4 Search List [ %] I
Search String: I

Find | |Fingnest| || Cancel |

2. Enter the text you want to search for and click the Find button. SeqLab
searches for the first occurrence of the string in all the sequences that
currently appear in the Main List. If a match is found, it is selected and
scrolled to the top of the Main List.

3. Click the Find Next button to find the next occurrence of the string, or
click Cancel to end the search.
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Arranging Items in a List

The Main List displays sequences in the order you added them to the list.
However, you may find it useful to organize your sequences alphabetically.
Or, you might want to arrange sequences so that those you use most often
appear at the top of the list.

Alphabetically Sorting List Items

Moving a List Item

above

below

P> To sort the items in the Main List into alphabetical order:

Choose Sort from the Edit menu. SeqLab sorts the sequences alphabetically.
To save the changes for next time you log in, choose Save List from the File
menu.

Note: You cannot move an item that is part of an expanded list (that is, an
item within a nested list, RSF, or MSF file). You also cannot select an item
within an expanded list, RSF, or MSF file as the location where you'd like to
move a chosen item.

P To move sequences from one position in a list to another:

1. Select the sequence(s) you want to move.

2. Choose Move... from the Edit menu. The Move Item dialog box appears,
instructing you to select the location in the Main List where you want to
move the item.

Select a position in the Main List

which you would like to mowve this item.

Cancel I

3. Click on the option menu to choose whether to move the item above or
below your chosen location. If you want to change this option, do so
before selecting your location. Or, to cancel the move, click the Cancel
button.
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Click above or below the sequence in the Main List where you want to
insert the moved sequence. The sequence is moved and the dialog box
closes.

(optional) To save the changes for the next time you log in, choose Save
List from the File menu.

Managing Your Sequence Projects [ 6-33



Reformatting Iitems in a List

You can reformat items in a list file into GCG, Staden, IntelliGenetics, PIR, or
FastA format. You can do this in two ways: 1) use the Extract Sequence...
function from the Edit menu on the Main List, or 2) use the programs
Reformat, ToStaden, ToIG, ToPIR, or ToFastA from Importing/Exporting in the
Functions menu. Note that sequences you reformat into Staden,
IntelliGenetics, or PIR format cannot be used by SeqLab.

P To reformat a sequence into GCG, Staden, IntelliGenetics (IG), PIR, or
FastA format:

Choose from the following.
ii  Use the Extract Sequence... function.

1. Select one item from the Main List. That item can be a single
sequence specification or a multiple sequence specification, such as a
list, RSF, or MSF file.

Note: You can format only single sequence specifications into Staden
Sformat.

2. Choose Extract Sequence... from the File menu. The Extract a List
Item dialog box appears.

4 Extract a List Item [ %] I

This extracts the entire forward strand of the
selected sequence into a file of the chosen format.

Qutput File Mame: II

Output Sequence Format: | GCG _II
OK I Closel
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3. (optional) Click the cursor in the Output File Name: text box and
change the name you want the output file saved as.

Output Sequence Format: GCG ﬂ
Staden 4. Click the Output Sequence Format: option menu to display the
G format types and choose one.
PIR
FastA 5. Click the OK button. The output file is written into your working

directory, or the directory you specified in the Output File Name: text
box.

Note: If you choose IG or PIR format, only one output file is created,
even if the item contains multiple sequence specifications.

If you choose GCG format, and the selected sequence is a multiple
sequence specification, then multiple files are written into your
working directory, and the Output File Name: specification is ignored.
(Seqlab uses the sequence name for the filename and the database
name in the extension, for example ldbb_chick.swissprot.) You may
want to use the Reformat program, which allows you to create an
output list file in addition to the newly reformaitted sequence files.

#i Use one of the Importing/Exporting programs: Reformat,
ToStaden, TolG, ToPIR, or ToFastA. For more information, see the
Program Manual.
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Saving Changes to a List File
The changes you make to a list file while it is open in the Main List are not
saved unless you explicitly save them.
P To save changes you have made to a list file:

Choose one of the following from the File menu.

Save List. Saves the changes into a list file of the same name.

Save List As.... Saves the changes into a list file of a different name.

A Save List [ %]

Mame of file to save list items in:

L |
3K Cancell

2@ Save Selected.... Saves only the selected (highlighted) sequences into a
list file with a name you specify.

4 Save Selected List [ %]

Mame of Selected List

| |
oK | Cancel |

Note: If you do not specify a directory, SeqLab saves the file in your working
directory.
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